Cisco Router Configuration Examples: EIGRP and RIP

Below are configuration examples for Cisco routers using EIGRP and RIP routing protocols.

Router R1 Configuration


enable
configure terminal
hostname R1
interface f0/0
ip address 10.0.232.1 255.255.255.192
no cdp enable
no shutdown
interface f0/1
ip address 10.0.232.65 255.255.255.252
no shutdown
router eigrp 100
no auto-summary
network 10.0.232.0 0.0.0.63
network 10.0.232.64 0.0.0.3
do wr

Router R2 Configuration


enable
configure terminal
hostname R2
interface f0/1
ip address 10.0.232.66 255.255.255.252
no shutdown
interface f0/0
ip address 10.0.232.69 255.255.255.252
no shutdown
interface f1/0
ip address 10.0.232.73 255.255.255.252
no shutdown
router eigrp 100
no auto-summary
network 10.0.232.64 0.0.0.3
network 10.0.232.68 0.0.0.3
network 10.0.232.72 0.0.0.3
do wr

Router R3 Configuration


enable
configure terminal
hostname R3
interface f0/0
ip address 10.0.232.70 255.255.255.252
no shutdown
interface f0/1
ip address 10.0.233.1 255.255.255.0
no cdp enable
no shutdown
router eigrp 100
no auto-summary
network 10.0.232.68 0.0.0.3
network 10.0.233.0
do wr

Router R4 Configuration


enable
configure terminal
hostname R4
interface f0/1
ip address 10.0.234.1 255.255.255.0
no cdp enable
no shutdown
interface f0/0
ip address 10.0.232.82 255.255.255.252
no shutdown
interface f1/1
ip address 10.0.235.1 255.255.255.0
no cdp enable
no shutdown
ip summary-address eigrp 100 10.0.234.0 255.255.254.0
router eigrp 100
no auto-summary
network 10.0.234.0
network 10.0.232.80 0.0.0.3
network 10.0.235.0
do wr

Router R5 Configuration


enable
configure terminal
hostname R5
interface f1/1
ip address 10.0.232.77 255.255.255.252
no shutdown
interface f0/0
ip address 10.0.232.81 255.255.255.252
no shutdown
router eigrp 100
no auto-summary
network 10.0.232.76 0.0.0.3
network 10.0.232.80 0.0.0.3
do wr

Router R6 Configuration


enable
configure terminal
hostname R6
interface f1/0
ip address 10.0.232.74 255.255.255.252
no shutdown
interface f1/1
ip address 10.0.232.78 255.255.255.252
no shutdown
interface f0/0
ip address 172.16.0.1 255.255.255.248
no shutdown
router eigrp 100
no auto-summary
network 10.0.232.72 0.0.0.3
network 10.0.232.76 0.0.0.3
network 172.16.0.0 0.0.0.7
do wr

Router R7 Configuration


enable
configure terminal
hostname R7
interface f0/0
ip address 172.16.0.2 255.255.255.248
no shutdown
interface f1/1
ip address 10.0.237.197 255.255.255.252
no shutdown
interface f1/0
ip address 10.0.237.193 255.255.255.252
no shutdown
router rip
version 2
network 10.0.237.192
network 10.0.237.196
do wr

Router R9 Configuration


enable
configure terminal
hostname R9
interface f1/1
ip address 10.0.237.198 255.255.255.252
no shutdown
interface f0/1
ip address 10.0.236.1 255.255.255.128
no shutdown
interface f0/0
ip address 10.0.236.129 255.255.255.128
no shutdown
router rip
version 2
network 10.0.236.0
do wr

Router R10 Configuration


enable
configure terminal
hostname R10
interface f1/0
ip address 10.0.237.194 255.255.255.252
no shutdown
interface f0/1
ip address 10.0.237.1 255.255.255.128
no shutdown
interface f0/0
ip address 10.0.237.129 255.255.255.192
no shutdown
router rip
version 2
network 10.0.237.0
do wr