Configuring Network Devices: Police, Fire, and Central HQ

This document outlines the configuration steps for network devices in a Police Department, Fire Department, and Central Headquarters environment. It includes router and switch configurations, VLAN setup, OSPF routing, DHCP configuration, and NAT setup.

Network Topology

The network consists of three main sites:

  • Police Department (Site 1)
  • Central Headquarters (HQ)
  • Fire Department (Site 2)

Router Configurations

Police Department Router Configuration

Router(config)# hostname PoliceDept
PoliceDept(config)# no ip domain-lookup
PoliceDept(config)# enable secret [password]
PoliceDept(config)# line con 0
PoliceDept(config-line)# logging synchronous
PoliceDept(config)# line console 0
password [password]
login
PoliceDept(config)# line vty 0 4
password [password]
login
PoliceDept(config)# service password-encryption
PoliceDept(config)# banner motd "message-of-the-day"

Interface Configuration – Police Department

PoliceDept(config)# interface Serial0/0/0
PoliceDept(config-if)# bandwidth 128
PoliceDept(config-if)# ip address 192.168.10.105 255.255.255.252
PoliceDept(config-if)# description Police and Central
PoliceDept(config-if)# clock rate 128000
PoliceDept(config-if)# no shutdown

Central Headquarters Router Configuration

Central(config)# interface Serial0/0/0
Central(config-if)# bandwidth 128
Central(config-if)# ip address 192.168.10.106 255.255.255.252
Central(config-if)# no shutdown

Central(config)# interface Serial0/0/1
Central(config-if)# bandwidth 128
Central(config-if)# ip address 192.168.10.114 255.255.255.252
Central(config-if)# clock rate 128000
Central(config-if)# no shutdown

Central(config)# interface g0/0
Central(config-if)# ip address 192.168.18.41 255.255.255.248
Central(config-if)# no shutdown

Central(config)# interface Serial0/1/0
Central(config-if)# ip address 198.51.100.1 255.255.255.240
Central(config-if)# no shutdown

Fire Department Router Configuration

Fire(config)# interface Serial0/0/1
Fire(config-if)# bandwidth 128
Fire(config-if)# ip address 198.51.100.1 255.255.255.240
Fire(config-if)# no shutdown

Static Routes

PoliceDept(config)# ip route 0.0.0.0 0.0.0.0 s0/0/0
Central(config)# ip route 0.0.0.0 0.0.0.0 s0/1/0
Fire(config)# ip route 0.0.0.0 0.0.0.0 s0/0/1
Central(config)# ip route 192.168.200.0 255.255.252.0 s0/0/1
Fire(config)# ip route 192.168.200.0 255.255.252.0 s0/0/0

OSPF Configuration

Police Department OSPF Configuration

PoliceDept(config)# router ospf 10
PoliceDept(config-router)# router-id 1.1.1.1
PoliceDept(config-router)# network 192.168.10.104 0.0.0.3 area 0
PoliceDept(config-router)# network 192.168.45.0 0.0.0.255 area 0
PoliceDept(config-router)# network 192.168.47.0 0.0.0.255 area 0
PoliceDept(config-router)# network 192.168.101.0 0.0.0.255 area 0
PoliceDept(config-router)# passive-interface g0/0.45
PoliceDept(config-router)# passive-interface g0/0.47
PoliceDept(config-router)# passive-interface g0/0.101
PoliceDept(config)# interface s0/0/0
PoliceDept(config-if)# bandwidth 128
PoliceDept(config-if)# ip ospf cost 7500

Central Headquarters OSPF Configuration

Central(config)# router ospf 10
Central(config-router)# router-id 2.2.2.2
Central(config-router)# network 192.168.10.104 0.0.0.3 area 0
Central(config-router)# network 192.168.10.112 0.0.0.3 area 0
Central(config-router)# network 192.168.18.40 0.0.0.7 area 0
Central(config-router)# passive-interface g0/0
Central(config)# interface s0/0/0
Central(config-if)# bandwidth 128
Central(config-if)# ip ospf cost 7500
Central(config)# interface s0/0/1
Central(config-if)# bandwidth 128

Fire Department OSPF Configuration

Fire(config)# router ospf 10
Fire(config-router)# router-id 3.3.3.3
Fire(config-router)# network 192.168.10.112 0.0.0.3 area 0
Fire(config)# interface s0/0/1
Fire(config-if)# bandwidth 128

Switch Configurations

VLAN Configuration

Police-SW1 and Police-SW2

Police-SW1(config)# vlan 45
Police-SW1(config-vlan)# name HR
Police-SW1(config)# vlan 47
Police-SW1(config-vlan)# name records
Police-SW1(config)# vlan 101
Police-SW1(config-vlan)# name comm

Police-SW2(config)# vlan 45
Police-SW2(config-vlan)# name HR
Police-SW2(config)# vlan 47
Police-SW2(config-vlan)# name records
Police-SW2(config)# vlan 101
Police-SW2(config-vlan)# name comm

Interface Configuration

Police-SW1(config)# int g1/1
Police-SW1(config-if)# switchport mode trunk
Police-SW1(config-if)# no shutdown
Police-SW1(config)# int g1/2
Police-SW1(config-if)# switchport mode trunk
Police-SW1(config-if)# no shutdown

Police-SW2(config)# int g1/1
Police-SW2(config-if)# switchport mode trunk
Police-SW2(config-if)# no shutdown

Police-SW1(config)# int fa0/10
Police-SW1(config-if)# switchport mode access
Police-SW1(config-if)# switchport access vlan 45
Police-SW1(config-if)# exit
Police-SW1(config)# int fa0/15
Police-SW1(config-if)# switchport mode access
Police-SW1(config-if)# switchport access vlan 47
Police-SW1(config-if)# exit

Police-SW2(config)# int fa0/3
Police-SW2(config-if)# switchport mode access
Police-SW2(config-if)# switchport access vlan 45
Police-SW2(config-if)# exit
Police-SW2(config)# int fa0/21
Police-SW2(config-if)# switchport mode access
Police-SW2(config-if)# switchport access vlan 47
Police-SW2(config-if)# exit

Default Gateway and VLAN Interface Configuration

Police-SW1(config)# ip default-gateway 192.168.101.1
Police-SW1(config)# interface vlan 101
Police-SW1(config-if)# ip address 192.168.101.2 255.255.255.0

Police-SW2(config)# ip default-gateway 192.168.101.1
Police-SW2(config)# interface vlan 101
Police-SW2(config-if)# ip address 192.168.101.3 255.255.255.0

Interface Shutdown

Police-SW1(config)# int range fa0/1-9, fa0/11-14, fa0/16-24
Police-SW1(config-if-range)# switchport mode access
Police-SW1(config-if-range)# shutdown

Police-SW2(config)# int range fa0/1-2, fa0/4-20, fa0/22-24
Police-SW2(config-if-range)# switchport mode access
Police-SW2(config-if-range)# shutdown

DHCP Configuration

PoliceDept(config)# ip dhcp excluded-address 192.168.45.1 192.168.45.20
PoliceDept(config)# ip dhcp excluded-address 192.168.47.1 192.168.47.20

PoliceDept(config)# ip dhcp pool VLAN45
PoliceDept(dhcp-config)# network 192.168.45.0 255.255.255.0
PoliceDept(dhcp-config)# default-router 192.168.45.1
PoliceDept(dhcp-config)# dns-server 192.168.18.100

PoliceDept(config)# ip dhcp pool VLAN47
PoliceDept(dhcp-config)# network 192.168.47.0 255.255.255.0
PoliceDept(dhcp-config)# default-router 192.168.47.1
PoliceDept(dhcp-config)# dns-server 192.168.18.100

NAT Configuration

Central(config)# ip nat inside source static 192.168.18.46 198.51.100.14
Central(config)# interface g0/0
Central(config-if)# ip nat inside
Central(config)# interface s0/1/0
Central(config-if)# ip nat outside

ip nat pool INTERNET 198.51.100.3 198.51.100.13 netmask 255.255.255.240
ip nat inside source list 1 pool INTERNET
ip nat inside source static 192.168.18.46 198.51.100.14
ip access-list standard 1
permit 192.168.45.0 0.0.0.255
permit 192.168.47.0 0.0.0.255
permit 192.168.200.0 0.0.3.255

Subinterface Configuration

PoliceDept(config)# interface g0/0
PoliceDept(config-if)# no sh
PoliceDept(config)# interface g0/0.45
PoliceDept(config-subif)# encapsulation dot1Q 45
PoliceDept(config-subif)# ip address 192.168.45.1 255.255.255.0
PoliceDept(config)# interface g0/0.47
PoliceDept(config-subif)# encapsulation dot1Q 47
PoliceDept(config-subif)# ip address 192.168.47.1 255.255.255.0
PoliceDept(config)# interface g0/0.101
PoliceDept(config-subif)# encapsulation dot1Q 101
PoliceDept(config-subif)# ip address 192.168.101.1 255.255.255.0