Network Configuration: Routers and Switches Setup
Posted on Feb 14, 2025 in Computing and Communications
Router R1 Configuration
hostname R1
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.0.0.1 255.255.248.0
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.0.8.1 255.255.252.0
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 10.0.12.1 255.255.252.0
interface FastEthernet0/0.40
encapsulation dot1Q 40
ip address 10.0.16.1 255.255.255.0
interface FastEthernet0/0.99
encapsulation dot1Q 99
ip address 1.1.1.1 255.0.0.0
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
interface Serial0/0/0
ip address 100.0.0.1 255.255.255.252
clock rate 128000
ip classless
ip route 0.0.0.0 0.0.0.0 100.0.0.2
!--- The following routes might be redundant or incorrect. Verify network topology. ---
ip route 0.0.0.0 0.0.0.0 10.0.0.0
ip route 0.0.0.0 0.0.0.0 10.0.8.0
ip route 0.0.0.0 0.0.0.0 10.0.12.0
ip route 0.0.0.0 0.0.0.0 10.0.16.0
Router R2 Configuration
hostname R2
interface FastEthernet0/0
ip address 192.168.70.1 255.255.0.0
duplex auto
speed auto
interface Serial0/0/0
ip address 100.0.0.2 255.255.255.252
interface Serial0/0/1
ip address 100.0.0.5 255.255.255.252
clock rate 128000
router eigrp 65000
network 192.168.70.0
network 100.0.0.4 0.0.0.3
network 100.0.0.0 0.0.0.3
auto-summary
router rip
redistribute static
ip classless
!--- The following routes might be redundant or incorrect. Verify network topology. ---
ip route 0.0.0.0 0.0.0.0 100.0.0.0
ip route 0.0.0.0 0.0.0.0 100.0.0.1
Router R3 Configuration
hostname R3
interface FastEthernet0/0
ip address 100.0.0.9 255.255.255.252
duplex auto
speed auto
interface FastEthernet0/1
ip address 100.0.0.13 255.255.255.252
duplex auto
speed auto
interface Serial0/0/1
ip address 100.0.0.6 255.255.255.252
router eigrp 65000
network 100.0.0.0 0.0.0.3
network 100.0.0.12 0.0.0.3
network 100.0.0.4 0.0.0.3
network 100.0.0.8 0.0.0.3
no auto-summary
Switch SW5 Configuration
hostname SW5
interface FastEthernet0/24
spanning-tree portfast
interface GigabitEthernet1/1
spanning-tree portfast
Switch SW1 Configuration
hostname SW1
spanning-tree vlan 10 priority 8192
interface range FastEthernet0/1-3
switchport access vlan 99
switchport trunk native vlan 99
switchport mode trunk
interface range FastEthernet0/4-9
switchport access vlan 10
switchport mode access
spanning-tree portfast
interface range FastEthernet0/10-13
switchport access vlan 20
switchport mode access
spanning-tree portfast
interface range FastEthernet0/13-18
switchport access vlan 30
switchport mode access
spanning-tree portfast
interface range FastEthernet0/19-23
switchport access vlan 40
switchport mode access
spanning-tree portfast
interface FastEthernet0/20
switchport access vlan 40
switchport mode access
spanning-tree portfast
interface FastEthernet0/24
switchport mode trunk
interface Vlan99
ip address 1.1.1.2 255.0.0.0
Switch SW4 Configuration
hostname SW4
spanning-tree vlan 40 priority 8192
interface range FastEthernet0/1-3
switchport access vlan 99
switchport trunk native vlan 99
switchport mode trunk
interface FastEthernet0/4
switchport access vlan 10
switchport mode access
switchport port-security mac-address sticky
spanning-tree portfast
interface range FastEthernet0/5-9
switchport access vlan 10
switchport trunk native vlan 99
switchport mode access
spanning-tree portfast
interface range FastEthernet0/10-12
switchport access vlan 20
switchport mode access
spanning-tree portfast
interface range FastEthernet0/13-18
switchport access vlan 30
switchport mode access
spanning-tree portfast
interface FastEthernet0/19
switchport access vlan 40
switchport mode access
spanning-tree portfast
interface FastEthernet0/20-21-23
switchport access vlan 40
switchport mode access
spanning-tree portfast
interface FastEthernet0/22
switchport access vlan 40
switchport mode access
spanning-tree portfast
switchport port-security mac-address 0001.9661.32CC
interface Vlan99
ip address 1.1.1.5 255.0.0.0