OSPF Configuration: Multi-Router Setup

OSPF Configuration for Multiple Routers

RTR-1 Configuration

enable
configure terminal
router ospf 10
exit
interface g0/0/0
ip ospf 10 area 0
interface s0/1/0
ip ospf 10 area 0
exit
router ospf 10
router-id 9.9.9.9
exit
interface g0/0/0
ip ospf priority 255
exit
ip route 0.0.0.0 0.0.0.0 s0/1/1
router ospf 10
default-information originate
exit
interface s0/1/0
ip ospf hello-interval 20
ip ospf dead-interval 80
exit
router ospf 10
auto-cost reference-bandwidth 10000
exit
router ospf 10
passive-interface s0/1/1
exit
ip nat inside source static 192.168.11.100 192.0.2.115
interface s0/1/1
ip nat outside
interface g0/0/0
ip nat inside
exit
access-list 1 permit 192.168.0.0 0.0.255.255
ip nat pool POOL-1 192.0.2.116 192.0.2.118 netmask 255.255.255.248
ip nat inside source list 1 pool POOL-1 overload
interface s0/1/0
ip nat inside
exit
ip access-list standard VTY-BLOCK
permit 192.168.0.0 0.0.255.255
deny any
exit
line vty 0 4
access-class VTY-BLOCK in
exit
end
copy running-config startup-config

Router 2 Configuration

enable
configure terminal
router ospf 10
exit
interface g0/0/0
ip ospf 10 area 0
interface g0/0/1
ip ospf 10 area 0
exit
router ospf 10
router-id 8.8.8.8
exit
router ospf 10
auto-cost reference-bandwidth 10000
exit
router ospf 10
passive-interface g0/0/0
exit
end
copy running-config startup-config

Router 3 Configuration

enable
configure terminal
router ospf 10
exit
interface g0/0/0
ip ospf 10 area 0
interface g0/0/1
ip ospf 10 area 0
exit
router ospf 10
router-id 7.7.7.7
exit
router ospf 10
auto-cost reference-bandwidth 10000
exit
router ospf 10
passive-interface g0/0/0
exit
access-list 10 deny 192.168.11.0 0.0.0.255
access-list 10 permit any
interface g0/0/1
ip access-group 10 in
exit
end
copy running-config startup-config

Router 4 Configuration

enable
configure terminal
router ospf 10
network 10.10.0.240 0.0.0.3 area 0
network 10.10.0.236 0.0.0.3 area 0
network 10.10.0.248 0.0.0.3 area 0
exit
interface s0/2/0
ip ospf hello-interval 20
ip ospf dead-interval 80
exit
router ospf 10
auto-cost reference-bandwidth 10000
exit
interface s0/1/1
ip ospf cost 50
exit
router ospf 10
passive-interface g0/0/0
exit
end
copy running-config startup-config

Router 5 Configuration

enable
configure terminal
router ospf 10
network 10.10.0.240 0.0.0.3 area 0
network 10.10.0.244 0.0.0.3 area 0
network 192.168.33.0 0.0.0.15 area 0
exit
router ospf 10
auto-cost reference-bandwidth 10000
exit
router ospf 10
passive-interface g0/0/0
exit
ntp server 192.168.33.14
exit
copy running-config startup-config

Router 6 Configuration

enable
configure terminal
router ospf 10
network 10.10.0.248 0.0.0.3 area 0
network 10.10.0.244 0.0.0.3 area 0
network 192.168.44.0 0.0.0.255 area 0
network 192.168.55.0 0.0.0.255 area 0
exit
router ospf 10
auto-cost reference-bandwidth 10000
exit
router ospf 10
passive-interface g0/0/0
passive-interface g0/0/1
exit
access-list 101 deny tcp any host 192.168.33.14 eq www
access-list 101 permit ip any any
interface g0/0/0
ip access-group 101 in
end
copy running-config startup-config

Router 5 (2) – Copying IOS Image via TFTP

PP-2>enable
PP-2#show flash:

System flash directory:
File Length Name/status
3 486899872 isr4300-universalk9.03.16.05.S.155-3.S5-ext.SPA.bin
2 28282 sigdef-category.xml
1 227537 sigdef-default.xml
[487155691 bytes used, 2761893909 available, 3249049600 total]
3.17338e+06K bytes of processor board System flash (Read/Write)

PP-2#copy flash tftp
Source filename []? isr4300-universalk9.03.16.05.S.155-3.S5-ext.SPA.bin
Address or name of remote host []? 192.168.33.14
Destination filename [isr4300-universalk9.03.16.05.S.155-3.S5-ext.SPA.bin]?