Setting Up an NFS Installation Server

Installation Server (First Virtual Machine)

Log in as root.

yum install system-config-kickstart nfs-utils
yum install gpm  (mouse support in console)
service gpm restart
vim /etc/idmapd.conf

Change the domain to:

Domain = virtual-server.local

Save the file :wq

vim /etc/exports

Add these lines (to create and share folders over the network):

/linux/x64              172.20.1.0/24    (ro,sync)    "Share the entire operating system"
/linux/ks               172.20.1.0/24    (ro,sync)    "Read only, synchronize"
Read More

Essential SQL Commands and Operations

CREATE: Create a New Table

CREATE TABLE employees (
  employee_id INT PRIMARY KEY,
  first_name VARCHAR(50),
  last_name VARCHAR(50),
  department VARCHAR(50),
  salary DECIMAL(10, 2)
);

INSERT INTO: Add New Records

INSERT INTO employees (employee_id, first_name, last_name, department, salary)
VALUES
  (1, 'John', 'Doe', 'HR', 50000.00),
  (2, 'Jane', 'Smith', 'IT', 60000.00),
  (3, 'Alice', 'Johnson', 'Finance', 55000.00),
  (4, 'Bob', 'Williams', 'IT', 62000.00),
  (5, 'Emily', 'Brown', 'HR', 
Read More

Configuring Network Devices: Police, Fire, and Central HQ

This document outlines the configuration steps for network devices in a Police Department, Fire Department, and Central Headquarters environment. It includes router and switch configurations, VLAN setup, OSPF routing, DHCP configuration, and NAT setup.

Network Topology

The network consists of three main sites:

  • Police Department (Site 1)
  • Central Headquarters (HQ)
  • Fire Department (Site 2)

Router Configurations

Police Department Router Configuration

Router(config)# hostname PoliceDept
PoliceDept(config)# no 
Read More

OSPF Configuration: Multi-Router Setup

OSPF Configuration for Multiple Routers

RTR-1 Configuration

enable
configure terminal
router ospf 10
exit
interface g0/0/0
ip ospf 10 area 0
interface s0/1/0
ip ospf 10 area 0
exit
router ospf 10
router-id 9.9.9.9
exit
interface g0/0/0
ip ospf priority 255
exit
ip route 0.0.0.0 0.0.0.0 s0/1/1
router ospf 10
default-information originate
exit
interface s0/1/0
ip ospf hello-interval 20
ip ospf dead-interval 80
exit
router ospf 10
auto-cost reference-bandwidth 10000
exit
router ospf 10
passive-interface 
Read More

Web Servers, FTP, and Content Management: A Technical Deep Dive

Update Content

Internet and Web Servers

Websites are hosted on computers called Web Servers. These servers use programs that accept requests from clients.

Examples of Web Servers:

  • IIS (Internet Information Server)
  • PWS (Personal Web Server)
  • WAMP (Windows + Apache + MySQL + PHP)
  • LAMP (Linux + Apache + MySQL + PHP)
  • XAMPP
  • Apache (.php)
  • Apache Tomcat (Pages .jsp)

Server Types

Read More

Network Configuration: Routers and Switches Setup

Router R1 Configuration

hostname R1

interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 10.0.0.1 255.255.248.0

interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 10.0.8.1 255.255.252.0

interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 10.0.12.1 255.255.252.0

interface FastEthernet0/0.40
 encapsulation dot1Q 40
 ip address 10.0.16.1 255.255.255.0

interface FastEthernet0/0.99
 encapsulation dot1Q 99
 ip address 1.1.1.1 255.0.0.0

interface FastEthernet0/
Read More